Получение PHP

Этот раздел содержит информацию о том, где получить PHP и вопросы, касающиеся OC.

Где я могу взять PHP?

Вы можете скачать PHP с любого сайта из сети сайтов PHP. Сайты сети можно найти на » http://www.php.net/. Вы также можете воспользоваться анонимным Git для получения самой последней версии исходников. За подробностями обращайтесь к » http://www.php.net/git.php.

Доступны ли прекомпилированные бинарники?

Мы распространяем прекомпилированные бинарники только для Windows, так как мы не в состоянии компилировать PHP со всеми возможными комбинациями расширений даже для самых основных Linux/Unix платформ. Также заметьте, что на сегодня многие дистрибутивы Linux поставляются с PHP. Бинарники для Windows можно скачать с нашей страницы » Downloads, для бинарников под Linux, пожалуйста, посетите web сайт вашего дистрибутива.

Где я могу достать библиотеки, необходимые для компиляции некоторых дополнительных расширений PHP?

Замечание: Звездочкой (*) помечены библиотеки, которые исходя из нашего опыта являются потоко не безопасными; эти библиотеки не рекомендуется использовать в многопоточной среде.

Как подключить эти библиотеки?

Вам необходимо следовать инструкциям, сопровождающим библиотеку. При запуске скрипта 'configure', некоторые библиотеки (такие как библиотека GD) находятся автоматически, другие должны быть включены с помощью опции '--with-EXTENSION' в 'configure'. Запустите 'configure --help' для получения списка всех опций.

Я получил последнюю версию исходников PHP из SVN. Что нужно для компиляции его под Windows?

Смотрите раздел руководства сборка PHP из исходников под Windows.

Где найти файл возможностей браузеров (Browser Capabilities File)?

Файл browscap.ini можно скачать с » http://browscap.org/.

Что означает потокобезопасность при скачке PHP?

Потокобезопасность означает, что данный бинарный файл может работать с многопоточным вебсервером, например таким, как Apache 2 под Windows. Потокобезопасность обеспечивается хранением локальных копий в каждом потоке, так что данные не вступят в противоречие с другим потоком.

Так что же выбрать? Если вы хотите использовать PHP в качестве бинарного файла CGI, то вам не нужна потокобезопасность, так как бинарный файл будет запускаться при каждом запросе. Для многопоточных вебсерверов, таких как IIS5 и IIS6, вам понадобится поточная версия PHP.

add a note add a note

User Contributed Notes 1 note

up
0
Anonymous
1 year ago
installation instructions are inside the downloaded zip of php
To Top
веселые картинки развлекательные гифки интресные факты смешные видео смешные истории из соцсетей