Переход с PHP 4 на PHP 5

Этот раздел поможет вам при переходе с PHP 4 на PHP 5.

Переход с PHP 4 на PHP 5

Хотя PHP 5 предлагает много новых возможностей, он проектировался для совместимости с ранними версиями PHP насколько это только возможно, с минимумом поломок функционала.

Не забудьте прочитать соответствующее приложение по переходу на PHP 5 в этом руководстве, так как оно содержит еще больше информации на тему мигрирования на PHP 5.

Работает ли MySQL в PHP 5? Похоже, она исчезла?

MySQL поддерживается с единственным изменением в том, что поддержка MySQL более не включена по умолчанию в PHP 5. Это главным образом означает, что PHP по умолчанию не включает опцию --with-mysql в строку для configure, поэтому вам надо сделать это вручную при компиляции PHP. Пользователи Windows должны будут отредактировать php.ini и включить php_mysql.dll DLL, так как эта DLL не существовала ранее в PHP 4, она была просто включена в бинарную версию PHP для Windows.

Также клиентские библиотеки MySQL больше не поставляются с PHP. Более подробно эта тема освещена здесь и для знания деталей установки MySQL обязательно еще прочитайте раздел по MySQL. Пример строки конфигурации: --with-mysql=/usr , в то время как пользователям Windows будет нужна доступная в системе libmySQL.dll.

Я слышал, что PHP 5 имеет полностью новую модель ООП, будет ли мой существующий код работать? Где найти информацию об этих новых возможностях ООП?

Основное изменение в PHP 5 - это изменение в модели ООП, так как PHP 5 теперь использует Zend Engine 2.0. Директива zend.ze1_compatibility_mode включает совместимость с Zend Engine 1.0 (PHP 4).

Новая модель ООП документирована в справочнике языка по ООП и приложении по переходу к ООП.

Что еще изменилось в PHP 5 кроме новой модели ООП? Также есть ли отдельная версия этого руководства для PHP 5?

Существует несколько других изменений, за подробностями обращайтесь в приложение по переходу на PHP 5. Специальной для PHP 5 версии этого руководства не будет, так как в основном объеме PHP остается все тем же.

add a note add a note

User Contributed Notes 2 notes

up
-3
gfrank at neoservers dot com
7 years ago
To get PHP5 and PHP4 to work at the same time you will also need to change all "php_value", "php_flag", "php_admin_flag", and "php_admin_value" occurences; otherwise, you can't set configuration file settings.
up
-5
odnowa-sql at o2 dot no-spam pl
7 years ago
You can run PHP4 and PHP5 as Apache2 modules at the same time. The trick is to hack the sources a little bit.
Change all occurences of application/x-httpd-php (and MIME type for sources) to application/x-httpd-php5 and then add that mime type to apache conf.
To Top
веселые картинки развлекательные гифки интресные факты смешные видео смешные истории из соцсетей